Discussion on some Code Issues

subhabangalore at gmail.com subhabangalore at gmail.com
Sun Jul 8 13:05:58 EDT 2012


On Sunday, July 8, 2012 1:33:25 PM UTC+5:30, Chris Angelico wrote:
> On Sun, Jul 8, 2012 at 3:42 PM,  <subhabangalore at gmail.com> wrote:
> > Thanks for pointing out the mistakes. Your points are right. So I am trying to revise it,
> >
> > file_open=open("/python32/doc1.txt","r")
> > for line in file_open:
> >          line_word=line.split()
> >          print (line_word)
> 
> Yep. I'd be inclined to rename file_open to something that says what
> the file _is_, and you may want to look into the 'with' statement to
> guarantee timely closure of the file, but that's a way to do it.
> 
> Also, as has already been mentioned: keeping your data files in the
> Python binaries directory isn't usually a good idea. More common to
> keep them in the same directory as your script, which would mean that
> you don't need a path on it at all.
> 
> ChrisA

Dear Chirs,
No file path! Amazing. I do not know I like to know one small example please. 
Btw, some earlier post said, line.split() to convert line into bag of words can be done with power(), but I did not find it, if any one can help. I do close files do not worry. New style I'd try.  

Regards,
Subha



More information about the Python-list mailing list