Discussion on some Code Issues

Chris Angelico rosuav at gmail.com
Sun Jul 8 04:03:25 EDT 2012


On Sun, Jul 8, 2012 at 3:42 PM,  <subhabangalore at gmail.com> wrote:
> Thanks for pointing out the mistakes. Your points are right. So I am trying to revise it,
>
> file_open=open("/python32/doc1.txt","r")
> for line in file_open:
>          line_word=line.split()
>          print (line_word)

Yep. I'd be inclined to rename file_open to something that says what
the file _is_, and you may want to look into the 'with' statement to
guarantee timely closure of the file, but that's a way to do it.

Also, as has already been mentioned: keeping your data files in the
Python binaries directory isn't usually a good idea. More common to
keep them in the same directory as your script, which would mean that
you don't need a path on it at all.

ChrisA



More information about the Python-list mailing list