CamelCase versus wide_names (Prothon)

Kevin Altis altis at semi-retired.com
Thu Apr 15 12:00:14 EDT 2004


If you're using PEP 8 terminology then CamelCase is different than
mixedCase. CamelCase is often used for class names and mixedCase for
everything else.

"""
- CapitalizedWords (or CapWords, or CamelCase -- so named because
      of the bumpy look of its letters[4]).  This is also sometimes known as
      StudlyCaps.

    - mixedCase (differs from CapitalizedWords by initial lowercase
      character!)
"""

ka

"Mark Hahn" <mark at prothon.org> wrote in message
news:UHxfc.9323$dZ1.3740 at fed1read04...
> We have agreed in Prothon that unlike Python we are going to be 100%
> consistant in our var and method naming.  We will not have run-together
> words like iteritems, we are going to always have seperated words like
> has_key.
>
> Now we are in the midst of a discussion of camelCase versus wide_names.
So
> far our arguments are:
>
> 1) CamelCase is more elegant, modern, more readable, and more efficient in
> character usage.
>
> 2) Wide_names is cleaner, more readable, compatible with C, which is the
> standard module language for Python and Prothon.  Wide_names is also the
> Python standard.
>
> Of course in the Python world you alread have wide_names as your standard,
> but could you for the moment pretend you were picking your standard from
> scratch (as we are doing in the Prothon world) and give your vote for
which
> you'd prefer?
>
> Thanks in advance...
>
>





More information about the Python-list mailing list