[Python-Dev] CVS: python/dist/src/Python sysmodule.c,2.59,2.60

bwarsaw@cnri.reston.va.us bwarsaw@cnri.reston.va.us
Thu, 13 Apr 2000 13:25:13 -0400 (EDT)


>>>>> "Fred" == Fred L Drake, Jr <fdrake@acm.org> writes:

    Fred>   Doesn't this further damage the human readability of the
    Fred> value?

A little, but it's a fine compromise between the various constraints.
Another way you could structure that tuple is to split the
PY_RELEASE_LEVEL and the PY_RELEASE_SERIAL.  Make the former even more
readable if you want, and make the latter a real int.  Thus Python
1.6a2 would have a sys.version_info() of (1, 6, 0, 'alpha', 2),
e.g. the form is:

    (major, minor, micro, level, serial)

You can't use 'gamma' though because then you break comparability.
Maybe use 'candidate' instead?  Sigh.

    Fred> I thought that was an important reason to break it
    Fred> up from sys.hexversion.  (Note also that you're not just
    Fred> saying more than 9 pre-releases, but more than 9 at any one
    Fred> of alpha, beta, or release candidate stages.  1-9 at each
    Fred> stage is already 27 pre-release packages.)

Well, Guido hisself must have thought that there was a remote
possibility of more than 9 releases at a particular level, otherwise
he'd have jammed PY_RELEASE_SERIAL in 3 bits.  I mean, there's no
other possible explanation for his choices is there?! :)

-Barry