[PYTHON MATRIX-SIG] naming conventions

Jim Hugunin hugunin@mit.edu
Wed, 14 Aug 1996 11:30:36 -0400


I'm cleaning up the naming conventions in preparation for the alpha2
release.  Basically there was a mixture of names like:

fromstring and arrayRange

Following the conventions of the python standard library, all of these
have been converted to:

arrayrange, astype, tolist, ...

I think this is the path of minimal confusion.

The functions that I'm not so happy with are the comparision functions
(for which I've never had great names anyway).

I decided to add an underscore to these names, which I think is also in
the python naming tradition, but is different from the other "two word"
names.

I now have: equal, not_equal, greater_equal, ...
and:  logical_and, boolean_and, ...

Also, I've decided to change the names of the precision functions
(previously Float, Integer, and Complex)

complexcode(32)
floatcode(32)
intcode(16)
...

These names are clearly much more consistent than the previous ones,
however, I still can see room for improvement.

As usual, comments are encouraged - Jim

=================
MATRIX-SIG  - SIG on Matrix Math for Python

send messages to: matrix-sig@python.org
administrivia to: matrix-sig-request@python.org
=================