Continuing indentation

sohcahtoa82 at gmail.com sohcahtoa82 at gmail.com
Fri Mar 4 20:17:53 EST 2016


On Friday, March 4, 2016 at 4:43:57 PM UTC-8, Simon Ward wrote:
> On 4 March 2016 23:31:43 GMT+00:00, Erik <python at lucidity.plus.com> wrote:
> >On 04/03/16 21:14, sohcahtoa82 at gmail.com wrote:
> >> You guys are spending way too much time fighting over something that
> >is clearly subjective.  Nobody is "correct" here.  There's no right and
> >wrong, just simple preference.
> >
> >I will take that as a vote +1 that PEP8 is wrong (*). ;)
> >
> >E.
> >
> >(*) PEP8 defines a specific format and you are stating that no specific
> >
> >format can be considered correct.
> 
> Style guides are always going to be considered incorrect by some people, but they should aim more for consistency (the hobgoblin that may be), which is what makes code easier to grok. Stop arguing, start thinking about others who will have to read your code. What is better in your subjective opinion means very little. Having commonly understandable style is what matters, and what style guides help (including PEP8).
> 
> Simon
> -- 
> Sent from Kaiten Mail. Please excuse my brevity.

Arguing whether or not a style guide is "incorrect" is as silly as arguing over whether lima beans are delicious.  I think they're disgusting, but you can't make a statement of fact about the topic.

Style guides are just guides.  They're a suggestion.  You can agree with them or disagree with them.  If I write a guide that dictates that every line of code should only include necessary indentation, a single token, and then a line continuation backslash if necessary, so code looks like this:

x \
= \
5
if \
y \
== \
z:
    print \
    'this is terrible'
    print \
    'but still not incorrect

It would be terrible, still but not incorrect.

This argument about whether binary operators should go on the end of one line or the beginning of the next is the C/C++/C#/Java/etc. fight about braces all over again.  It is entirely subjective, and I find it absolutely ridiculous that so many people are willing to argue until they're blue in the face about it.

If you're doing your own project, do it however you like it and ignore anyone that tells you that you're doing it "wrong".  Not formatting your code to match PEP 8 doesn't make your code formatted wrong, it just means you're choosing not to follow PEP 8 to a T.  Personally, I hate underscores in variable names that aren't constants.  I much prefer myVariableName over my_variable_name.  I think using underscores creates a sort of white space that makes it harder to read.  Do I think that people that use underscores are wrong?  No.  They just have a different opinion.

I just can't understand why so many people get their panties all up in a bunch over how other people choose to format their code.



More information about the Python-list mailing list