do...until wisdom found...

Dennis Baker drbaker at softhome.net
Tue Apr 17 12:19:12 EDT 2001


On Mon, 16 Apr 2001 23:02:21 -0700 "Ken Peek" <Peek at LVCM.comNOSPAM> wrote:

) In MY new language (NOT Python, but a new language "in the nature of" Python):

With the tons of existing languages out there why do you need another?
 
) I would make the "do/until" syntax like this:
) 
) do:
)     # some stuff
)     # some more stuff
)     until condition

Why don't you just use :

while condition:
   # Do some stuff...
   # Do More stuff

That way when you are reading the code you can see at the beginning of the loop what condition terminates the loop.  Make debugging more intuitive and programs more readable.  I rarely use "while true:" because it is pretty silly to code unless you really what an infinite loop (event drivin stuff usually... ).

) Can anybody think of a good name for a "Python-like" new language for small
) embedded processors?
) Let's see-- "tinyPython"?  nope-- has "Python" in it-- might make Guido mad.
) Hmmm, maybe "Dragon"?  Probably used by someone else?  Hmmm... maybe ???

How about "DoPython" seeing as the only change you've proposed is trivial and doesn't really add any value to the language it seems pointless to really make a significant change to the name.




More information about the Python-list mailing list