[Python-Dev] PEP 3144 review.

Peter Moody peter at hda3.com
Thu Sep 17 05:26:27 CEST 2009


On Wed, Sep 16, 2009 at 7:48 PM, Greg Ewing <greg.ewing at canterbury.ac.nz> wrote:
> Peter Moody wrote:
>>
>> I don't see where the confusion lies.  You have an address
>> + netmask. ergo, you have a Network object.  The single address that
>> defines the base address (most commonly referred to as the network
>> address) is an Address object. there is no netmask associated with
>> that single address, ergo, it's an Address object.
>
> But if I understand correctly, you *don't* have a network,
> you have something representing a particular host address
> within a network, plus information that lets you deduce the
> network to which it belongs. So calling the object a
> 'Network' is a misnomer.
>
> What's more, I don't see the point of having a 'network'
> attribute without a mask, because the zero address of a
> network on its own doesn't define the network. You need
> the zero address plus a mask to do that.
>
> I'm not sure what usefulness the zero address on its own
> has, but if it's considered useful enough to have an
> attribute for it, calling it something like 'base_address'
> would be less confusing.

the address with all of the hosts bits masked to zero is most commonly
referred to as the network address. same as the address with all of
the host bits set to one is called the broadcast address. calling it
something like base_address or min_address will cause quite a bit more
confusion.

>
> --
> Greg
> _______________________________________________
> Python-Dev mailing list
> Python-Dev at python.org
> http://mail.python.org/mailman/listinfo/python-dev
> Unsubscribe:
> http://mail.python.org/mailman/options/python-dev/python-dev%40hda3.com
>


More information about the Python-Dev mailing list