[Python-Dev] PEP 3144 review.

Greg Ewing greg.ewing at canterbury.ac.nz
Thu Sep 17 04:48:59 CEST 2009


Peter Moody wrote:
> I don't see where the confusion lies.  You have an address
> + netmask. ergo, you have a Network object.  The single address that
> defines the base address (most commonly referred to as the network
> address) is an Address object. there is no netmask associated with
> that single address, ergo, it's an Address object.

But if I understand correctly, you *don't* have a network,
you have something representing a particular host address
within a network, plus information that lets you deduce the
network to which it belongs. So calling the object a
'Network' is a misnomer.

What's more, I don't see the point of having a 'network'
attribute without a mask, because the zero address of a
network on its own doesn't define the network. You need
the zero address plus a mask to do that.

I'm not sure what usefulness the zero address on its own
has, but if it's considered useful enough to have an
attribute for it, calling it something like 'base_address'
would be less confusing.

-- 
Greg


More information about the Python-Dev mailing list