[Tutor] programming style question:

Thomas CLive Richards thomi@thomi.imail.net.nz
Wed May 7 01:54:02 2003


Hey!

I'm doing a degree course in Dunedin, New Zealand, and as part of this we have to do a pascal assignment. Well, to cut a long story short, i handed in my assignment, and was marked down because i used the following structure for a loop: (obviously i wrote this in pascal):

while 1:
	do_lots_of_things_here()
	if (condition):
		break
...

Now, the alternative would have (in my mind anyway) been more convoluted, and harder to read. What do you all think? It is a bit off topic, but do you guys think programming style is a personal thing, or should there be set rules? 
Things like "do i use a for or while loop here? In pascal it's pretty much up to you; both are usable. what do you think?

thanks,

-- 

Thomi Richards,
thomi@thomi.imail.net.nz