[Python-Dev] (no subject)

Neil Girdhar mistersheik at gmail.com
Tue Feb 10 08:16:40 CET 2015


On Tue, Feb 10, 2015 at 2:08 AM, Victor Stinner <victor.stinner at gmail.com>
wrote:

>
> Le 10 févr. 2015 03:07, "Ethan Furman" <ethan at stoneleaf.us> a écrit :
> > That line should read
> >
> >     return func(*(args + fargs), **{**keywords, **fkeywords})
> >
> > to avoid the duplicate key error and keep the original functionality.
>
> To me, this is just ugly. It prefers the original code which use .update().
>
> Maybe the PEP should be changed to behave as .update()?
>
> Victor
>
>
Just for clarity, Ethan is right, but it could also be written:

return func(*args, *fargs, **{**keywords, **fkeywords})

Best,

Neil


> _______________________________________________
> Python-Dev mailing list
> Python-Dev at python.org
> https://mail.python.org/mailman/listinfo/python-dev
> Unsubscribe:
> https://mail.python.org/mailman/options/python-dev/mistersheik%40gmail.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-dev/attachments/20150210/03bede29/attachment.html>


More information about the Python-Dev mailing list