[Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

R. David Murray rdmurray at bitdance.com
Sat Oct 12 00:49:16 CEST 2013


On Fri, 11 Oct 2013 16:09:56 -0300, Zero Piraeus <z at etiol.net> wrote:
> :
> 
> On Fri, Oct 11, 2013 at 08:01:07PM +0100, MRAB wrote:
> > On 11/10/2013 19:41, Glenn Linderman wrote:
> > >Insistence on using "with" for the anti-pattern, and proper English,
> > >would require:
> > >
> > >with ignorance_of(FileNotFoundError)
> > >
> > "Ignorance" means not knowing, but we _do_ know about FileNotFoundError.
> > What we want is to ignore it.
> 
> Suggestions:
> 
>     with disregard_for(...):
> 
>     with indifference_to(...):
> 
>     with nonchalance_regarding(...):
> 
>     with blithe_disdain_concerning(...):

    with an_immediate_exit_from_the_with_if_we_see(...):

--David


More information about the Python-Dev mailing list