[Python-Dev] Rename time.steady(strict=True) to time.monotonic()?

Yury Selivanov yselivanov.ml at gmail.com
Sat Mar 24 00:42:17 CET 2012


On 2012-03-23, at 7:25 PM, Victor Stinner wrote:

> - time.steady(): monotonic clock or the realtime clock, depending on
> what is available on the platform (use monotonic in priority). may be
> adjusted by NTP or the system administrator, may go backward.
> 
> time.steady() is something like:
> 
> try:
>  return time.monotonic()
> except (NotImplementError, OSError):
>  return time.time()

Is the use of weak monotonic time so wide-spread in the stdlib that we 
need the 'steady()' function?  If it's just two modules then it's not 
worth adding it.

-
Yury


More information about the Python-Dev mailing list