[Python-checkins] bpo-38526: Fix zipfile.Path method name to be the correct one (GH-17317)

Miss Islington (bot) webhook-mailer at python.org
Thu Nov 21 16:41:26 EST 2019


https://github.com/python/cpython/commit/107ed88cde3ae6f1cb01ae75575ea0f92c138464
commit: 107ed88cde3ae6f1cb01ae75575ea0f92c138464
branch: 3.8
author: Miss Islington (bot) <31488909+miss-islington at users.noreply.github.com>
committer: GitHub <noreply at github.com>
date: 2019-11-21T13:41:20-08:00
summary:

bpo-38526: Fix zipfile.Path method name to be the correct one (GH-17317)

(cherry picked from commit 65444cf7fe84d8ca1f9b51c7f5992210751e08bb)

Co-authored-by: Claudiu Popa <pcmanticore at gmail.com>

files:
M Doc/library/zipfile.rst

diff --git a/Doc/library/zipfile.rst b/Doc/library/zipfile.rst
index 18d2e9a60a7ba..e8a2530fb8c17 100644
--- a/Doc/library/zipfile.rst
+++ b/Doc/library/zipfile.rst
@@ -494,7 +494,7 @@ Path objects are traversable using the ``/`` operator.
    Invoke :meth:`ZipFile.open` on the current path. Accepts
    the same arguments as :meth:`ZipFile.open`.
 
-.. method:: Path.listdir()
+.. method:: Path.iterdir()
 
    Enumerate the children of the current directory.
 



More information about the Python-checkins mailing list