[Python-checkins] bpo-19119: Remove invalid test and rename a misnamed test (GH-15442)

Raymond Hettinger webhook-mailer at python.org
Sat Aug 24 01:31:26 EDT 2019


https://github.com/python/cpython/commit/4101181fd87c2fab6456663d3c8cc99377cf0463
commit: 4101181fd87c2fab6456663d3c8cc99377cf0463
branch: master
author: Raymond Hettinger <rhettinger at users.noreply.github.com>
committer: GitHub <noreply at github.com>
date: 2019-08-23T22:31:22-07:00
summary:

bpo-19119: Remove invalid test and rename a misnamed test (GH-15442)

files:
M Lib/test/test_heapq.py

diff --git a/Lib/test/test_heapq.py b/Lib/test/test_heapq.py
index 6c20b6297dfc..861ba7540df2 100644
--- a/Lib/test/test_heapq.py
+++ b/Lib/test/test_heapq.py
@@ -280,11 +280,6 @@ class LenOnly:
     def __len__(self):
         return 10
 
-class GetOnly:
-    "Dummy sequence class defining __getitem__ but not __len__."
-    def __getitem__(self, ndx):
-        return 10
-
 class CmpErr:
     "Dummy element that always raises an error during comparison"
     def __eq__(self, other):
@@ -396,15 +391,7 @@ def test_len_only(self):
         for f in (self.module.nlargest, self.module.nsmallest):
             self.assertRaises(TypeError, f, 2, LenOnly())
 
-    def test_get_only(self):
-        for f in (self.module.heapify, self.module.heappop):
-            self.assertRaises(TypeError, f, GetOnly())
-        for f in (self.module.heappush, self.module.heapreplace):
-            self.assertRaises(TypeError, f, GetOnly(), 10)
-        for f in (self.module.nlargest, self.module.nsmallest):
-            self.assertRaises(TypeError, f, 2, GetOnly())
-
-    def test_get_only(self):
+    def test_cmp_err(self):
         seq = [CmpErr(), CmpErr(), CmpErr()]
         for f in (self.module.heapify, self.module.heappop):
             self.assertRaises(ZeroDivisionError, f, seq)



More information about the Python-checkins mailing list