[Python-checkins] cpython: issue27985 - fix the incorrect duplicate class name in the lib2to3

gregory.p.smith python-checkins at python.org
Fri Sep 9 17:48:16 EDT 2016


https://hg.python.org/cpython/rev/ef3d30cc6b4f
changeset:   103469:ef3d30cc6b4f
parent:      103467:a25c39873d93
user:        Gregory P. Smith <greg at krypto.org>
date:        Fri Sep 09 14:48:08 2016 -0700
summary:
  issue27985 - fix the incorrect duplicate class name in the lib2to3
test.  call it TestVarAnnotations instead.

files:
  Lib/lib2to3/tests/test_parser.py |  2 +-
  1 files changed, 1 insertions(+), 1 deletions(-)


diff --git a/Lib/lib2to3/tests/test_parser.py b/Lib/lib2to3/tests/test_parser.py
--- a/Lib/lib2to3/tests/test_parser.py
+++ b/Lib/lib2to3/tests/test_parser.py
@@ -256,7 +256,7 @@
 
 
 # Adapted from Python 3's Lib/test/test_grammar.py:GrammarTests.test_var_annot
-class TestFunctionAnnotations(GrammarTest):
+class TestVarAnnotations(GrammarTest):
     def test_1(self):
         self.validate("var1: int = 5")
 

-- 
Repository URL: https://hg.python.org/cpython


More information about the Python-checkins mailing list