[Python-checkins] r64768 - in python/trunk/Lib: asynchat.py asyncore.py test/test_asyncore.py

Nick Coghlan ncoghlan at gmail.com
Mon Jul 7 15:13:20 CEST 2008


josiah.carlson wrote:
> Modified: python/trunk/Lib/asynchat.py
> ==============================================================================
> --- python/trunk/Lib/asynchat.py	(original)
> +++ python/trunk/Lib/asynchat.py	Mon Jul  7 06:51:46 2008
> @@ -59,7 +59,7 @@
>      ac_in_buffer_size       = 4096
>      ac_out_buffer_size      = 4096
>  
> -    def __init__ (self, conn=None):
> +    def __init__ (self, sock=None, map=None):
>          # for string terminator matching
>          self.ac_in_buffer = ''

Won't that change break any code calling asyncore.dispatcher with 
keyword arguments? Was there a specific reason for changing the name of 
the first argument from conn to sock?

Cheers,
Nick.

-- 
Nick Coghlan   |   ncoghlan at gmail.com   |   Brisbane, Australia
---------------------------------------------------------------
             http://www.boredomandlaziness.org


More information about the Python-checkins mailing list