[Python-checkins] r55431 - peps/trunk/pep-3100.txt

guido.van.rossum python-checkins at python.org
Fri May 18 16:45:00 CEST 2007


Author: guido.van.rossum
Date: Fri May 18 16:44:56 2007
New Revision: 55431

Modified:
   peps/trunk/pep-3100.txt
Log:
Clarify that filter and map stay but will return iterators.


Modified: peps/trunk/pep-3100.txt
==============================================================================
--- peps/trunk/pep-3100.txt	(original)
+++ peps/trunk/pep-3100.txt	Fri May 18 16:44:56 2007
@@ -167,7 +167,7 @@
 ==================
 
 * Make built-ins return an iterator where appropriate (e.g. ``range()``,
-  ``zip()``, etc.) [zip is done; Neal Norwitz has a patch for range()]
+  ``zip()``, ``map()``, ``filter()``, etc.) [zip and range: done]
 * Relevant functions should consume iterators (e.g. ``min()``,
   ``max()``) [They already do, since 2.2.]
 * Remove ``input()`` and rename ``raw_input()`` to ``input()``.
@@ -186,8 +186,6 @@
 * ``coerce()``: no longer needed [2]_
 * ``execfile()``, ``reload()``: use ``exec()`` [2]_
 * ``intern()``: put in ``sys`` [2]_, [22]_ [done]
-* ``map()``, ``filter()``: use list comprehensions instead??? [1]_, [9]_
-  (Actually these can stay.)
 * ``reduce()``: write a loop instead [2]_, [9]_ [done]
 * ``xrange()``: use ``range()`` instead [1]_ [See range() above]
 


More information about the Python-checkins mailing list