[issue46777] Fix incorrect use of directives in asyncio documentation

Andrew Svetlov report at bugs.python.org
Fri Feb 18 05:40:45 EST 2022


Andrew Svetlov <andrew.svetlov at gmail.com> added the comment:

> 6. The loop parameter of Task() was documented as both removed and required (if there is no current event loop) in 3.10.

I think we should drop Task() constructor definition from Task Object docs https://docs.python.org/3/library/asyncio-task.html#task-object but create 'asyncio-extending.rst' (suggest better name please) with low-level task documentation for guys who want to create their own task class.

Task constructor could be documented here along with `_register_task()`, `_enter_task()`, `_leave_task()`, `_unregister_task()`. They might be useful for ones who implements a custom task factories.

----------

_______________________________________
Python tracker <report at bugs.python.org>
<https://bugs.python.org/issue46777>
_______________________________________


More information about the Python-bugs-list mailing list