[issue23193] Please support "numeric_owner" in tarfile

Berker Peksag report at bugs.python.org
Tue Apr 14 06:33:22 CEST 2015


Berker Peksag added the comment:

* +.. method:: TarFile.extractall(path=".", members=None, numeric_owner=False)

  numeric_owner can be a keyword-only argument.

* TarFile.extract and TarFile.extractall docs need a versionchanged directive.

* It would be nice to add an entry to Doc/whatsnew/3.5.rst

* +        filename_1 = fname
  +        dirname_1 = dirname
  +        filename_2 = os.path.join(dirname, fname)

  I'd just yield fname, dirname, os.path.join(dirname, fname) here.

* +            for name, uid, gid, typ, contents in [(fname, 99, 98, tarfile.REGTYPE, fobj),
  +                                                  (dirname, 77, 76, tarfile.DIRTYPE, None),
  +                                                  (os.path.join(dirname, fname), 88, 87, tarfile.REGTYPE, fobj),
  +                                                  ]:

  Moving the list to a new variable would be more readable.

* Typo: # ceate -> # create

* +def root_is_uid_gid_0():

  Question: Can't we use something like root_in_posix in test_os here?

* +        with tarfile.open(tar_filename) as r:

  Nitpick: What does "r" mean here? "tar" or "tarobj" looks more readable to me.

* Nitpick: I'd prefer ``None`` over :const:`True`. However, the current style is just "true" in the tarfile documentation.

----------

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue23193>
_______________________________________


More information about the Python-bugs-list mailing list