[issue15502] Meta path finders and path entry finders are different, but share an ABC

Eric Snow report at bugs.python.org
Tue Jul 31 08:03:16 CEST 2012


Eric Snow added the comment:

Yeah, but right now the API of importlib.abc.Finder is strictly find_module(name, path=None).  I would expect that to remain the same for MetaPathFinder (bikeshedding aside :).  So what would be left in importlib.abc.Finder if the ultimate plan is that PathEntryHandler would not implement find_module()?  Would it simply be an alias to MetaPathFinder?

I agree with the plan, but wonder if a common base class is warranted.  The connection to "finder" in PEP 302 is nice, but rather superfluous in a practical context.  Having a Finder class is necessary at this point for backward-compatibility, but I don't see how it is different from the more appropriately named MetaPathFinder.

----------

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue15502>
_______________________________________


More information about the Python-bugs-list mailing list