[py-svn] r62111 - in py/branch/pytestplugin/py/test: plugin testing

hpk at codespeak.net hpk at codespeak.net
Tue Feb 24 15:26:24 CET 2009


Author: hpk
Date: Tue Feb 24 15:26:24 2009
New Revision: 62111

Modified:
   py/branch/pytestplugin/py/test/plugin/pytest_xfail.py
   py/branch/pytestplugin/py/test/testing/test_pytestplugin.py
Log:
remove superflous test related to last checkin, and tweak xfail reporting


Modified: py/branch/pytestplugin/py/test/plugin/pytest_xfail.py
==============================================================================
--- py/branch/pytestplugin/py/test/plugin/pytest_xfail.py	(original)
+++ py/branch/pytestplugin/py/test/plugin/pytest_xfail.py	Tue Feb 24 15:26:24 2009
@@ -27,7 +27,7 @@
                 entry = event.longrepr.reprcrash 
                 key = entry.path, entry.lineno, entry.message
                 reason = event.longrepr.reprcrash.message
-                modpath = event.colitem.getmodpath(stopatmodule=False)
+                modpath = event.colitem.getmodpath(stopatmodule=True)
                 #tr._tw.line("%s %s:%d: %s" %(modpath, entry.path, entry.lineno, entry.message))
                 tr._tw.line("%s %s:%d: " %(modpath, entry.path, entry.lineno))
 

Modified: py/branch/pytestplugin/py/test/testing/test_pytestplugin.py
==============================================================================
--- py/branch/pytestplugin/py/test/testing/test_pytestplugin.py	(original)
+++ py/branch/pytestplugin/py/test/testing/test_pytestplugin.py	Tue Feb 24 15:26:24 2009
@@ -161,17 +161,6 @@
         assert plugins.getplugin("plug1").__class__.__name__ == "Plug1Plugin"
         assert plugins.getplugin("plug2").__class__.__name__ == "Plug2Plugin"
 
-    @py.test.keywords(xfail="getplugin() naming is unclear unconcept")
-    def test_getplugin(self):
-        plugins = PytestPlugins()
-        assert py.test.raises(LookupError, "plugins.getplugin('_xxx')")
-
-        class PluGin: pass 
-        plugins.register(PluGin())
-        myplugin1 = plugins.getplugin("plugin")
-        myplugin2 = plugins.getplugin("Plugin") 
-        assert myplugin1 is myplugin2 
-
 class TestPluginInteraction:
     def test_getfirst(self):
         plugins = PytestPlugins()



More information about the pytest-commit mailing list