[pypy-commit] pypy arm-backed-float: (arigo, bivab) give generated functions more meaningful names

bivab noreply at buildbot.pypy.org
Wed Jun 8 18:23:36 CEST 2011


Author: David Schneider <david.schneider at picle.org>
Branch: arm-backed-float
Changeset: r44837:65d69628e74d
Date: 2011-06-08 18:24 +0200
http://bitbucket.org/pypy/pypy/changeset/65d69628e74d/

Log:	(arigo, bivab) give generated functions more meaningful names

diff --git a/pypy/jit/backend/arm/instruction_builder.py b/pypy/jit/backend/arm/instruction_builder.py
--- a/pypy/jit/backend/arm/instruction_builder.py
+++ b/pypy/jit/backend/arm/instruction_builder.py
@@ -359,6 +359,7 @@
             continue
         try:
             func = globals()['define_%s_func' % name]
+            func.__name__ = name
         except KeyError:
             print 'No instr generator for %s instructions' % name
             continue


More information about the pypy-commit mailing list