[Distutils] A possible refactor/streamlining of PEP 517

Daniel Holth dholth at gmail.com
Tue Jul 11 11:48:29 EDT 2017


On Tue, Jul 11, 2017 at 9:58 AM Thomas Kluyver <thomas at kluyver.me.uk> wrote:

> To summarise the current state of this discussion as I understand it,
> the hooks we are currently thinking of defining are:
>
> def get_build_wheel_requires(config_settings)
> def prepare_wheel_metadata(metadata_directory, config_settings)
> def build_wheel(wheel_directory, config_settings, build_directory=None,
> metadata_directory=None)
>
> def get_build_sdist_requires(config_settings)
> def build_sdist(sdist_directory, config_settings[,
> build_directory=None])  # Last param under discussion
>
> I know we were also discussing a different naming scheme, but I've
> forgotten what names were proposed, and don't have time to find the
> relevant email again. Could someone produce a copy of the list above
> with the proposed names substituted?
>

Pro_duced.

Mandatory backend hooks:

- build_sdist(sdist_directory, config_settings={})
- build_wheel(wheel_directory, config_settings={}, build_directory=None,
metadata_directory=None)

Optional backend hooks:

- get_requires_for_build_sdist(config_settings={})
- get_requires_for_build_wheel(config_settings={})
- prepare_metadata_for_build_wheel(metadata_directory, config_settings={})
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20170711/546fb324/attachment-0001.html>


More information about the Distutils-SIG mailing list