[Distutils] Naming conventions for module unit tests?

Todd Greenwood-Geer tgreenwoodgeer at yahoo.com
Wed Dec 14 19:18:22 CET 2005


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

To the list :

Anyone have any good naming conventions for module tests?

[module name]_unittest.py
test_[module_name].py
unittest_[module_name].py

Then there's the issue of differentiating unit tests from functional
tests, scenario tests...

Here's my off the cuff definition for these things:

unit test : fine grained tests, usually testing individual methods
functional test : coarser grained tests, usually testing an aggregation
of methods, usually a single module
scenario tests : even coarser grained tests, not focused on code testing
per se, focused on testing actual usage scenarios from beginning to end.

Then there are the aggregations of tests, drts and bvts.

Anyone out there come across a useful naming structure for all this?

Perhaps:
[aggregation]_[level]_[module].py
	drt_unittest_foo.py
	bvt_functionaltest_foo.py

Or am I overly complicating things again?

- -Todd

John J Lee wrote:
| On Sat, 10 Dec 2005, Todd Greenwood-Geer wrote:
|
|> -----BEGIN PGP SIGNED MESSAGE-----
|> Hash: SHA1
|>
|> Thanks John. That was biting me in several places. Is there a standard
|> practice/naming convention for module unit tests? I was trying something
|> like [module name]_unittest.py.
|
| That's a list question, surely -- post to the list!
|
|
| John
|
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDoGHuz6uXX4lQc/URAntjAJ0UAs/e4CP7LO/y0w/ukO57TSRoVQCaApbC
1My/W9koS6HaJ1aeh4pGdWU=
=eWeG
-----END PGP SIGNATURE-----


More information about the Distutils-SIG mailing list