[C++-sig] Re: New slice implementation

David Abrahams dave at boost-consulting.com
Mon Jan 19 18:13:46 CET 2004


Jonathan Brandmeyer <jbrandmeyer at earthlink.net> writes:

> On Wed, 2004-01-14 at 00:02, David Abrahams wrote:
>> David Abrahams <dave at boost-consulting.com> writes:
>> 
>> > BTW, compare this with the HTML source for list.html and you'll see
>> > one of the main reasons people hate HTML to be edited with WYSIWYG
>> > tools.  Sticking  tags in a  block is just insane.
>> 
>> Not that you're insane; it's your editor ;-)
>
> I understand.  Its fixed, I think.
>
>> Note also:
>> 
>>   slice::get_indicies(RandomAccessIterator const& begin, RandomAccessIterator const& end);
>> 
>> Is probably too wide and should be wrapped:
>> 
>>   slice::get_indicies(
>>       RandomAccessIterator const& begin, RandomAccessIterator const& end);
>
> Done.

Much better.  Preformatted text is still too wide in places (including
the one I pointed at above, sorry).  Also, the Throws clause from
get_indicies leaves out which Python exception is raised.  You should
use the "raise" term as defined here:

http://www.boost.org/libs/python/doc/v2/definitions.html#raise

So you can avoid writing error_already_set over and over.  You can use
a hyperlink if you think it's needed for clarity.

I think with those small changes it will be ready.  Send me your
sourceforge user id (the textual one) and I'll give you Boost CVS
access so you can check this in yourself.

-- 
Dave Abrahams
Boost Consulting
www.boost-consulting.com





More information about the Cplusplus-sig mailing list