[Web-SIG] Random thoughts

Ian Bicking ianb at colorstudy.com
Mon Nov 3 11:19:28 EST 2003


On Nov 3, 2003, at 9:07 AM, Gregory (Grisha) Trubetskoy wrote:
> On Mon, 3 Nov 2003, John J Lee wrote:
>
>> On Mon, 3 Nov 2003, Steve Holden wrote:
>> [...]
>>> On balance, your suggestion seems the most practical except for the
>>> naming (form-data is not a valid name). Maybe formargs and 
>>> queryargs, or
>>> formdata and querydata, or some such, leaving the user to merge the 
>>> two
>>> sets as (and only when) required.
>> [...]
>>
>> 'form' seems bad because form data can be in the URL-encoded data, not
>> only in the POST data.  How about postdata and querydata?
>
> I like "post" and "query" as a qualifier to "form data", after reading 
> all
> this RFC stuff, this seems most standard compliant.
>
> request.form(query_overrides=1)   <-- returns both
> request.form.postdata()
> request.form.querydata()

Seems a little long-winded.  How about request.formdata, .postdata, 
.querydata, where .formdata is postdata+querydata?  (In practice most 
people use the combined version)

They could be proper dictionary-like objects.  Though if they aren't 
real dictionaries, I suppose we would have:

request.fields, request.fields.post, request.fields.query, each of 
which implements a dictionary interface.

--
Ian Bicking | ianb at colorstudy.com | http://blog.ianbicking.org




More information about the Web-SIG mailing list