[SciPy-user] New name for Scipy Core is NumPy

Travis Oliphant oliphant.travis at ieee.org
Thu Jan 5 05:39:05 EST 2006


There has been a fast-paced discussion on the scipy-dev list which 
resulted in the renaming of the scipy_core package to numpy in 
preparation for the 0.9. 2 (nearing stable 1.0 release).

You now need to get numpy out of svn:

svn co http://svn.scipy.org/svn/numpy/trunk numpy

and build it before building scipy  (numpy replaces scipy_core)

Also,  you must explicitly call scipy.pkgload() if you want to load the 
scipy namespace with the numpy names (and the scipy sub-package names).  
Otherwise, scipy acts more like a library (you have to explicitly import 
scipy.linalg)

This new packaging structure makes things much nicer for .eggs and 
should mean a more stable platform in the long run.  The only big 
porting effort is to use  replace scipy.base with numpy  and/or

import scipy
scipy.pkgload()

An actual release of numpy and scipy will follow.

Best regards,

-Travis





More information about the SciPy-User mailing list