Root logger sanity

Antoon Pardon antoon.pardon at rece.vub.ac.be
Thu Mar 19 06:09:42 EDT 2015


On 03/19/2015 10:35 AM, martin.spamer at gmail.com wrote:
> The following code is challenging my sanity, in my understanding of the documentation this should pass, given that getLogger is supposed to return the root logger and the root logger should be called 'root'.

Where do you get the idea that the root logger should be called 'root'?
AFAIU the documentation the root logger is nameless. So

logging.getLogger() will return the root logger while

logging.getLogger('root') will return the logger named 'root'

which are two different loggers.

>
> https://docs.python.org/2/library/logging.html#logger-objects
>
> What am I missing?
>
>
> from unittest import TestCase
> import logging
>
> class LoggingSanityTest(TestCase):
>
>     def test_root_logging_sanity(self):
>         assert logging.getLogger() == logging.getLogger('root')




More information about the Python-list mailing list