pylint, was Re: pygame - importing GL - very bad...

Mike C. Fletcher mcfletch at vrplumber.com
Thu Jan 3 09:19:19 EST 2013


On 13-01-02 09:48 PM, Terry Reedy wrote:
...
> 2) self.lightDone: Invalid name "lightDone" (should match
>> [a-z_][a-z0-9_]{2,30}$)
>>
>> So I can now understand that pylint doesn't like my naming convention
>> with a capital letter in the middle of the variable name, like:
>> "lightDone" = a boolean value. I suppose pylint wants me to use (a
>> little longer method) an underscore to separate words in long variable
>> names...
>
> That is more conventional in the Python community (and is in pep 8, I 
> believe) but still a choice.
That seems like a improper error message from the tool.  "Invalid name" 
does *not* properly describe that situation.  The name is *not* 
"Invalid" in any sense of the word, and a "checker" that tells you it is 
is creating needless false-positives.  An error checker should be saying 
something like:

     "self.lightDone: Does not match PEP8 recommended style"

making it clear that this is *not* an error, it is a *style* related 
*warning*.

HTH,
Mike

-- 
________________________________________________
   Mike C. Fletcher
   Designer, VR Plumber, Coder
   http://www.vrplumber.com
   http://blog.vrplumber.com




More information about the Python-list mailing list