classes and sub classes?

Jason Friedman jsf80238 at gmail.com
Sun Apr 14 21:38:37 EDT 2013


> NwInvDb = NetworkInventoryDatabase, yes you are correct, it creates the
database handle and makes it ready for use.

I am interested in opinions.  I for one dislike abbreviations on the theory
that programs are read more than they are written.  I would probably use
this variable name:

network_inventory_db_connection = ...

And yes, I'm aware that "db" is an abbreviation.  I believe I am following
a few Zen principles:

Beautiful is better than ugly.
Explicit is better than implicit.
Readability counts.
Special cases aren't special enough to break the rules, Although
practicality beats purity.

What would others use?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-list/attachments/20130414/06c5b205/attachment.html>


More information about the Python-list mailing list