avoid the redefinition of a function

Alister alister.ware at ntlworld.com
Wed Sep 12 14:04:51 EDT 2012


On Wed, 12 Sep 2012 18:56:46 +0200, Jabba Laci wrote:

>> For example:
>>
>> def install_java():
>>    pass
>>
>> def install_tomcat():
>>    pass
> 
> Thanks for the answers. I decided to use numbers in the name of the
> functions to facilitate function calls. Now if you have this menu option
> for instance:
> 
> (5) install mc
> 
> You can type just "5" as user input and step_5() is called
> automatically. If I use descriptive names like install_java() then
> selecting a menu point would be more difficult. And I don't want users
> to type "java", I want to stick to simple numbers.
> 
> Laszlo

No No NO!
you cant just pass user input to system calls without validating it first
(google sql injection for examples of the damage unsanitised input can 
cause, it is not just as SQL problem)

it is just as easy so select a reasonably named function as a bad one

option=raw_input('select your option :')

if option =="1": install_java()
if option =="2": install_other()

alternatively you cold add your functions into a dictionary an call them 
from that

opts={'1':install java,'2':install_other}

option=raw_input('select your option :')
opts[option]

Poorly named functions are a major example of poor programming style.

one of the fundamental pillars for python is readability!



-- 
<knghtbrd> He's a about half the size of the others.
<knghtbrd> But he's got a chainsaw.



More information about the Python-list mailing list