TkInter bind() event is not firing event trigger

rantingrick rantingrick at gmail.com
Tue Jun 22 20:55:13 EDT 2010


On Jun 22, 7:39 pm, MRAB <pyt... at mrabarnett.plus.com> wrote:

> http://www.pythonware.com/library/tkinter/introduction/events-and-bin...
>
> it's '<Double-Button-1>'.

Yes and i vehemently hate these names! Just hideous if you ask me.

@ Anthony
Also be sure to use an "event name" for an event function/method and
use the docstring to describe what the event will do. Do NOT use the
method name to describe this like you have done. It's also a good idea
to start event methods with "on". This is fairly well recognized as an
event naming convention...

onMotion()
onButtonOneClick()
onKeyPress()
onEnter()
onConfigure()
...etc

...Just ideas folks, just ideas!



More information about the Python-list mailing list