Regarding coding style

castironpi at gmail.com castironpi at gmail.com
Sun Mar 9 18:34:19 EDT 2008


> > >> Good comments are better than bad names. Good names are better than bad
> > >> comments.
>
> > > If you're taking the time to write good comments, why not just fix the
> > > bad names?  The compiler/interpreter can never, ever catch bad comments.
>
> > Yes, but the Python compiler can only catch bad names if you do this at
> > the top of every module:
>
> > import semantic_analysis
> > import magic.crystal_ball.read_programmers_mind
>
> dir( magic )!
> dir( magic.crystal_ball )?

Someone should try annotating code with a dictionary lookup on
identifiers.  Anyone bored on Fridays?  No one should try printing out
the definitions in real-time as the code is executing.



More information about the Python-list mailing list