ANN: pry unit testing framework

Kay Schluehr kay.schluehr at gmx.net
Sat Apr 5 05:51:41 EDT 2008


On 5 Apr., 10:26, Aldo Cortesi <a... at nullcube.com> wrote:

> So, why did I re-write it? Well, I needed a test framework that didn't
> have the deep flaws that unittest has. I needed good hierarchical
> fixture management. I needed something that didn't instantiate test
> suites automatically, freeing me to use inheritance more naturally
> within my test suites.

I'm not entirely sure what you are claiming here. From source
inspections I can see that TestSuite instances are instantiated by the
TestLoader and you are free to derive from TestLoader, overwrite its
methods and pass around another instance than defaultTestLoader  ( or
a fresh instance of TestLoader which is the same thing ).

My impression is that unittest is bashed so much because it has Java
style naming conventions i.e. for bike shading reasons not because
people come up with a much improved way to create test frameworks or
even understand what a framework is and create a new one just for
applying a different default behaviour.

The split into TestLoader, TestRunner, TestCase and TestSuite is
pretty canonical and I still fail to see what can't be done with them
and OO techniques.




More information about the Python-list mailing list