When is List Comprehension inappropriate?

Aahz aahz at pythoncraft.com
Tue Mar 20 09:12:23 EDT 2007


In article <1hv8wz8.19mj0kb1k9m2m8N%aleax at mac.com>,
Alex Martelli <aleax at mac.com> wrote:
>
>list(iterimage(etc etc))
>
>is surely a better way to express identical semantics.  More generally,
>[x for x in whatever] (whether x is a single name or gets peculiarly
>unpacked and repacked like here) is a good example of inappropriate LC,
>to get back to the question in the subject: list(whatever) is the "one
>obvious way" to perform the same task.

Except of course, when it's

[x for x in whatever if x]

I'm exceedingly fond of replacing filter() with listcomps.  They're so
much more readable and often faster.
-- 
Aahz (aahz at pythoncraft.com)           <*>         http://www.pythoncraft.com/

"Typing is cheap.  Thinking is expensive."  --Roy Smith



More information about the Python-list mailing list