*Naming Conventions*

Steve Howell showell30 at yahoo.com
Sun Jun 3 19:39:23 EDT 2007


--- Dan Bishop <danb_83 at yahoo.com> wrote:
> 
> * Loop indices often have single-letter names
> (typically i/j/k or x/
> y), or names that are the singular form of the list
> name (e.g., "for
> ballot in self._ballots").  For iterating over
> files, I use "line".
>

You are in good company with "i" and "line."  They are
among the 15 most used tokens in the Python standard
library, which includes reserved words if, def,
return, in, not, else, and for.

16610 self
7347 if
5222 def
4686 return
2818 None
2235 in
1799 not
1723 else
1637 name
1499 i
1226 os
1224 line
1203 for
1183 data
1181 path
 
I sampled /usr/local/lib/python2.5 with tokenizer.



       
____________________________________________________________________________________
Got a little couch potato? 
Check out fun summer activities for kids.
http://search.yahoo.com/search?fr=oni_on_mail&p=summer+activities+for+kids&cs=bz 



More information about the Python-list mailing list