Extract String From Enclosing Tuple

Ben Finney bignose+hates-spam at benfinney.id.au
Wed Feb 28 18:30:14 EST 2007


Ben Finney <bignose+hates-spam at benfinney.id.au> writes:

> orders = (
> [...]
> )
>
> order_items = (
> [...]
> )

For clarity, these sequences of records should be lists (with each
item being a tuple containing the record fields), not tuples.

A tuple implies a meaning associated with each position in the
sequence (like a record with a positional meaning for each field), a
list implies the opposite (a sequence with order but not meaning
associated with each position).

-- 
 \     "If you were going to shoot a mime, would you use a silencer?"  |
  `\                                                  -- Steven Wright |
_o__)                                                                  |
Ben Finney




More information about the Python-list mailing list