beginner, idomatic python 2

Bruno Desthuilliers bruno.42.desthuilliers at wtf.websiteburo.oops.com
Fri Aug 24 03:48:24 EDT 2007


bambam a écrit :
> Would someone like to suggest a replacement for this? This is a
> function that returns different kinds of similar objects, depending
> on what is asked for. PSP and PWR are classes.  I don't really
> want to re-write the calling code very much: I'm just wondering
> if the function can be replaced with some kind of OOP pattern.

Dan already answered to this. Just as a side note, and since you're 
trying to be "idiomatic", Python's naming convention is to use all_lower 
for functions, MixedCaps for classes (except - mostly for historical 
reasons - the builtin types...), and ALL_LOWER for symbolic (pseudo) 
constants.


> def Device(DeviceType):
>     if DeviceType=='PSP':
>         return PSP()
>     elif DeviceType=="Power Supply"
>         return PWR()
>     etc...
> 
> 
> Thanks! 
> 
> 



More information about the Python-list mailing list