Request for help on naming conventions

Steven D'Aprano steve at REMOVETHIScyber.com.au
Mon Jun 13 04:59:37 EDT 2005


Are there any useful naming conventions for modules, classes and functions?

For instance, should I name functions as verbs and classes as nouns?

eg 
class Transformer():
    pass

def transform():
    do_stuff

What about the module name? transformations.py or transform.py?

What do people do with their own code? Do folks find that being
consistent helps them remember what is what, or do you name objects
whatever feels right at the time?


-- 
Steven.




More information about the Python-list mailing list