What about an EXPLICIT naming scheme for built-ins?

Carlos Ribeiro carribeiro at gmail.com
Fri Sep 3 16:57:58 EDT 2004


On Fri, 03 Sep 2004 20:26:13 GMT, Paul McGuire
<ptmcg at austin.rr._bogus_.com> wrote:
> (What if you wrote a sorted_iter that would iterate over an existing list in
> sorted order?)

I wrote about it earlier today. The proper way to do it is through a
generator. This way you can sort a sequence and use just a small part
of it -- maybe just the top few items or so. I proposed the name
xsorted() to keep company with xrange(), but that's being deprecated,
so I really don't know if it's worth it at this point.


-- 
Carlos Ribeiro
Consultoria em Projetos
blog: http://rascunhosrotos.blogspot.com
blog: http://pythonnotes.blogspot.com
mail: carribeiro at gmail.com
mail: carribeiro at yahoo.com



More information about the Python-list mailing list