PEP318 alternate syntax idea

Stephen Horne steve at ninereeds.fsnet.co.uk
Tue Mar 23 05:59:02 EST 2004


On 23 Mar 2004 12:08:01 +0200, Ville Vainio <ville at spammers.com>
wrote:

>>>>>> "Stephen" == Stephen Horne <steve at ninereeds.fsnet.co.uk> writes:
>
>    Stephen> It just occurred to me that if decorators really catch
>    Stephen> on, there could be cases where they are applied
>    Stephen> repeatedly to many functions, and possibly with many
>    Stephen> decorators. Combine that with many (and variable numbers
>    Stephen> of) parameters per function and readability could be
>    Stephen> seriously hit.
>
>d = publishdecorator
>
>def f() [d]:
>        pass

Do we really want people writing...

d = lambda x : staticmethod (someotherdecoration (whateverdeco (x))

def f() [d] :
  pass


-- 
Steve Horne

steve at ninereeds dot fsnet dot co dot uk



More information about the Python-list mailing list