PEP318 alternate syntax idea

Ville Vainio ville at spammers.com
Tue Mar 23 05:08:01 EST 2004


>>>>> "Stephen" == Stephen Horne <steve at ninereeds.fsnet.co.uk> writes:

    Stephen> It just occurred to me that if decorators really catch
    Stephen> on, there could be cases where they are applied
    Stephen> repeatedly to many functions, and possibly with many
    Stephen> decorators. Combine that with many (and variable numbers
    Stephen> of) parameters per function and readability could be
    Stephen> seriously hit.

d = publishdecorator

def f() [d]:
        pass

def g() [d]:
        pass

d = hidedecorator

def f2() [d]:
        pass

def g2() [d]:
        pass

-- 
Ville Vainio   http://tinyurl.com/2prnb



More information about the Python-list mailing list