Python indentation

Marc Boeren m.boeren at guidance.nl
Thu Jul 8 03:47:16 EDT 2004


>     Damn skippy.  'round these parts it would look like this:
> 
> if (condition) {
>     doThis();
>     doThat();
> }
> else {
>     doWhatever();
>     andSoOn();
> }

Nearly there. It should of course look like this:

if (condition) {
    doThis();
    doThat();
    }
else {
    doWhatever();
    andSoOn();
    }

which is as close as you're going to get to python-like readability :-)

Cheerio, Marc.



More information about the Python-list mailing list