Express What, not How.

Raffael Cavallaro raffaelcavallaro at junk.mail.me.not.mac.com
Fri Oct 17 01:43:06 EDT 2003


In article <bmnl9e$e8g$1 at news-int.gatech.edu>,
 gt5163b at prism.gatech.edu (Brian McNamara!) wrote:


[snip]
>   \fn -> do info <- processFile fn
>              printInfo info
> and
>    \fn -> do info <- processFile fn
>              saveInfo info (fn++".sav")

[snip]

> What ought I call them?  Perhaps
> "processFileAndPrint" and "processFileAndSave"?

Yup. Next question. Only someone who hasn't taken a break from coding 
for a long time could think that:

\fn -> do info <- processFile fn
               printInfo info

is clearer or easier to understand than:

ProcessFileAndPrint


Even more so in lisp:

process-file-and-print




More information about the Python-list mailing list