Comments on my "Python Introduction" slides

Miki Tebeka tebeka at cs.bgu.ac.il
Tue Aug 26 06:10:50 EDT 2003


Hello Bryan,

> not sure it's any better, faster, more readable... just my preference.  so your frame 7 would be:
> 
> def unique(fname):
>    '''Prints unique lines in fname'''
>     h = {}
>     for line in file(fname):
>         line = line.strip()
>         if line not in h:
>             h[line] = True
>             print line
> 
Taken. It's in.


> frame 8:  you should also list empty tuple, list and dict as having a False value too)
Don't they fall under "empty collection"?

> frame 9:  needs a note that it's for 2.3+
That's the current official release.

> frame 10: IMO "Magic methods" has a negative connotation.  but maybe it's the correct terminology
I'll try to find a better alternative.

> frame 12: i know python has a c interface for c extension modules, but can't modules also be written is c++ (ie. boost?)
You're right. I guess I hate C++ to much :-)

> frame 18-19: i would show the exact same example in each.
I'll do this oraly.
>  it appears from your slide that wxPython is way more complicated than TK
wxPython is more sutibale for large project and requires a bit more
overhead than Tk to start up. Can't think of anything shorter.

> i enjoyed going though it... nice work...
Thanks.

Thanks for you comments.
Miki




More information about the Python-list mailing list