Naming higher order functions

Erno Kuusela erno-news at erno.iki.fi
Thu Jan 31 09:52:40 EST 2002


hello,

what would be a good name for the following function?

def name_me(n):
    def g(x):
        return x[n]
    return g

"make_nth_getter" came to mind but it doesn't sound that good to me.

  -- erno



More information about the Python-list mailing list