[Python-ideas] PEP: Extended stat_result (First Draft)

Oleg Broytman phd at phdru.name
Mon May 6 19:56:17 CEST 2013


On Mon, May 06, 2013 at 07:33:13PM +0200, Pieter Nagel <pieter at nagel.co.za> wrote:
> On Mon, 2013-05-06 at 20:55 +0400, Oleg Broytman wrote:
> 
> >    Shouldn't it be called filemode()? I see you are fond of underscores
> > but Python style guides discourage using them AFAIK.
> 
> Actually, PEP 8 says "Function names should be lowercase, with words
> separated by underscores as necessary to improve readability."

   Yes, but stdlib doesn't follow this style. See, for example, built-in
functions -- http://docs.python.org/library/functions.html :

staticmethod() isinstance() basestring() execfile() issubclass() bytearray()
frozenset() classmethod() getattr() hasattr() memoryview() delattr() setattr()

   I'm sure this style is codified somewhere, don't know where.

Oleg.
-- 
     Oleg Broytman            http://phdru.name/            phd at phdru.name
           Programmers don't die, they just GOSUB without RETURN.



More information about the Python-ideas mailing list