[Python-Dev] Second post: PEP 557, Data Classes

Eric V. Smith eric at trueblade.com
Sat Nov 25 19:44:00 EST 2017


One more change:

  - Per-field metadata, for use by third parties.

Also, thanks to Guido and Ivan for all of their feedback on the various 
issues that got the PEP to this point.

Eric.

On 11/25/2017 4:06 PM, Eric V. Smith wrote:
> The updated version should show up at 
> https://www.python.org/dev/peps/pep-0557/ shortly.
> 
> The major changes from the previous version are:
> 
> - Add InitVar to specify initialize-only fields.
> - Renamed __dataclass_post_init__() to __post_init().
> - Rename cmp to compare.
> - Added eq, separate from compare, so you can test
>    unorderable items for equality.
> - Flushed out asdict() and astuple().
> - Changed replace() to just call __init__(), and dropped
>    the complex post-create logic.
> 
> The only open issues I know of are:
> - Should object comparison require an exact match on the type?
>    https://github.com/ericvsmith/dataclasses/issues/51
> - Should the replace() function be renamed to something else?
>    https://github.com/ericvsmith/dataclasses/issues/77
> 
> Most of the items that were previously discussed on python-dev were 
> discussed in detail at https://github.com/ericvsmith/dataclasses. Before 
> rehashing an old discussion, please check there first.
> 
> Also at https://github.com/ericvsmith/dataclasses is an implementation, 
> with tests, that should work with 3.6 and 3.7. The only action item for 
> the code is to clean up the implementation of InitVar, but that's 
> waiting for PEP 560. Oh, and if PEP 563 is accepted I'll also need to do 
> some work.
> 
> Feedback is welcomed!
> 
> Eric.
> _______________________________________________
> Python-Dev mailing list
> Python-Dev at python.org
> https://mail.python.org/mailman/listinfo/python-dev
> Unsubscribe: 
> https://mail.python.org/mailman/options/python-dev/eric%2Ba-python-dev%40trueblade.com 
> 



More information about the Python-Dev mailing list