[Python-Dev] decorator module patch

Steven Bethard steven.bethard at gmail.com
Mon Mar 13 00:12:46 CET 2006


On 3/12/06, Raymond Hettinger <raymond.hettinger at verizon.net> wrote:
> [Nick Coghlan]
> > I agree it makes sense to have "decorator", "memoize", "deprecated" and
> > "partial" all being members of the same module, whether the name be
> > "functools" or "functional" (although I have a slight preference for
> > "functools" due to the parallel with "itertools").
>
> I like "functools" for a different reason -- the name is sufficiently broad so
> that we don't have fret about whether a particular tool fits within the module's
> scope.  In contrast, a name like "functional" suggests that some of these tools
> don't quite fit.

FWIW, +1 here.  Especially if we're only going to add two functions --
``partial``, which is already accepted, and Georg's ``decorator`` --
it seems like overkill to introduce a module for each.  I agree that
"functools" is a better module name if both ``partial`` and
``decorator`` are going in there.

STeVe
--
Grammar am for people who can't think for myself.
        --- Bucky Katt, Get Fuzzy


More information about the Python-Dev mailing list